Student Game Temporarily Unavailable – We’re On It!
Incident Report for
Boddle Learning
Resolved
The game is back up and running! If you run into any trouble, please don't hesitate to reach out to our team.
Posted
May
01
,
2026
-
09:54
CDT
Monitoring
The game should be back up for most users. We'll continue monitoring for further issues on our end.
Posted
May
01
,
2026
-
09:37
CDT
Identified
Our team is restarting the affected servers and we should be back up and running in just a few minutes!
Posted
May
01
,
2026
-
09:32
CDT
Investigating
The student game is experiencing a temporary outage but will be back up soon. We’re looking into it and will update here shortly!
Posted
May
01
,
2026
-
09:05
CDT
This incident affected: Boddle Game.
×
Subscribe to Incident
Subscribe to updates for
Student Game Temporarily Unavailable – We’re On It!
via . You'll receive .