We've made some major changes to increase our server capacity and the game is significantly more stable as a result! We'll continue to monitor usage and make changes as necessary.
Posted Oct 14, 2025 - 14:30 CDT
Update
We’re working on some big fixes this week to speed up the game. Some users may experience issues logging in during this time.
Posted Sep 23, 2025 - 13:34 CDT
Update
The game is currently down for all users. We will update here as soon as it's back up and running!
Posted Sep 23, 2025 - 12:35 CDT
Monitoring
We’re working on some big fixes this week to speed up the game. Some users may experience issues logging in during this time
Posted Sep 22, 2025 - 09:57 CDT
Update
We’re working on some big fixes this week to speed up the game. Some users may experience issues logging in during this time.
Posted Sep 22, 2025 - 09:57 CDT
Update
We're in the process of moving to a new server to resolve ongoing network issues. As we make these changes, the student game may be unstable or unavailable. We anticipate this process to be completed sometime next week!
Posted Sep 19, 2025 - 11:09 CDT
Update
We're in the process of moving to a new server to resolve ongoing network issues. As we make these changes, the student game may be unstable or unavailable. We anticipate this process to be completed sometime next week!
Posted Sep 19, 2025 - 10:31 CDT
Investigating
The student game is experiencing a temporary outage but will be back up soon. We’re looking into it and will update here shortly!