Student Game Temporarily Unavailable – We’re On It!
Incident Report for
Boddle Learning
Resolved
We are back up and running! Thanks so much for your patience!
Posted
Sep
12
,
2025
-
10:02
CDT
Investigating
The student game is experiencing a temporary outage but will be back up soon. We’re looking into it and will update here shortly!
Posted
Sep
12
,
2025
-
09:25
CDT
This incident affected: Boddle Game.
×
Subscribe to Incident
Subscribe to updates for
Student Game Temporarily Unavailable – We’re On It!
via . You'll receive .