The provider has resolved the outage on their end, and everything should be up and running!
Posted Oct 21, 2025 - 13:23 CDT
Identified
We’re seeing some slowdowns due to an issue with one of our network providers. Our team is working to minimize the impact and get things back to normal soon. Thanks for bearing with us!
Posted Oct 20, 2025 - 10:58 CDT
This incident affected: Boddle Game and Teacher and Parent Portal.