Game Server Maintenance Ongoing 🚧

Incident Report for Boddle Learning

Resolved

The server maintenance has been completed! Thanks so much for your patience!
Posted Sep 15, 2025 - 10:57 CDT

Identified

The student game is currently undergoing maintenance to improve performance, so certain users may experience login issues. We appreciate your patience as we work to make the game better than ever!
Posted Sep 15, 2025 - 08:52 CDT

Investigating

The student game is experiencing a temporary outage but will be back up soon. We’re looking into it and will update here shortly!
Posted Sep 15, 2025 - 08:25 CDT
This incident affected: Boddle Game.