Student Game Temporarily Unavailable – We’re On It!

Incident Report for Boddle Learning

Resolved

The game is back up and running at full speed. Thanks for your patience!
Posted Dec 18, 2025 - 11:58 CST

Monitoring

The student game is back up and running, but some features may load slowly as our servers recover. We'll continue monitoring.
Posted Dec 18, 2025 - 11:21 CST

Investigating

The student game is experiencing a temporary outage but will be back up soon. We’re looking into it and will update here shortly!
Posted Dec 18, 2025 - 10:28 CST
This incident affected: Boddle Game.