Student Game Unavailable for the Next Few Hours

Incident Report for Boddle Learning

Resolved

The game is back up and running! If you're having trouble signing in, please refresh your browser or restart the app.
Posted Sep 09, 2025 - 13:20 CDT

Identified

Our team has identified the issue and is working on a fix. We anticipate that this will take a few hours to complete. Thank you so much for your patience!
Posted Sep 09, 2025 - 11:10 CDT

Investigating

The student game is experiencing a temporary outage but will be back up soon. We’re looking into it and will update here shortly!
Posted Sep 09, 2025 - 08:59 CDT
This incident affected: Boddle Game.