The Student Game is Stable - We're Monitoring Our Server

Incident Report for Boddle Learning

Monitoring

The game is back up and stable. We'll continue montioring our server.
Posted Dec 11, 2025 - 10:33 CST

Investigating

The student game is experiencing a temporary outage but will be back up soon. We’re looking into it and will update here shortly!
Posted Dec 11, 2025 - 09:33 CST
This incident affects: Boddle Game.