Slow Loading Possible

Incident Report for Boddle Learning

Resolved

We are back up to full speed!
Posted Nov 17, 2025 - 08:26 CST

Investigating

One of our servers is experiencing downtime, so some users may experience extended wait times when signing in. Our team is working on getting things back up to speed!
Posted Nov 14, 2025 - 10:14 CST

Monitoring

The server is back up and running and we're monitoring to ensure stability.
Posted Nov 14, 2025 - 10:00 CST

Investigating

One of our servers is experiencing downtime, so some users may experience extended wait times when signing in. Our team is working on getting things back up to speed!
Posted Nov 14, 2025 - 09:43 CST
This incident affected: Boddle Game.