Server Restart in Progress π
Incident Report for
Boddle Learning
Resolved
Maintenance is complete and the game is back up and running!
Posted
Nov
12
,
2025
-
10:34
CST
Investigating
Heads up! Our server will be down for the next few minutes as we complete some quick maintenance. We'll be back up and running shortly!
Posted
Nov
12
,
2025
-
10:23
CST
This incident affected: Boddle Game.
Γ
Subscribe to Incident
Subscribe to updates for
Server Restart in Progress π
via . You'll receive .