Teacher and Parent Portals Temporarily Unavailable
Incident Report for
Boddle Learning
Resolved
The teacher and parent portals are back up and running. Thanks so much for your patience!
Posted
Dec
18
,
2025
-
10:52
CST
Investigating
Both the teacher and parent portals are currently down. We’re looking into the issue and will provide updates shortly!
Posted
Dec
18
,
2025
-
10:28
CST
This incident affected: Teacher and Parent Portal.
×
Subscribe to Incident
Subscribe to updates for
Teacher and Parent Portals Temporarily Unavailable
via . You'll receive .