This issue should now be resolved for all users. Thank you for your patience!
Posted Oct 30, 2025 - 10:54 CDT
Monitoring
We've launched a fix and are monitoring to ensure everything is working properly.
Posted Oct 30, 2025 - 10:26 CDT
Investigating
We’re aware of an issue preventing students from switching subjects in the game. Our team is already working on a fix and we’ll update this page once it’s resolved.