Student Loading Errors Possible

Incident Report for Boddle Learning

Resolved

All servers are back to normal! Thanks for your patience.
Posted Oct 14, 2025 - 14:29 CDT

Investigating

One of our servers is experiencing downtime, so some users may be unable to sign in. Our team is working on getting it back up and running as quickly as possible.
Posted Oct 14, 2025 - 14:22 CDT
This incident affected: Boddle Game.