Student Game Temporarily Unavailable – We’re On It!

Incident Report for Boddle Learning

Resolved

The game is back up and running! Thanks so much for your patience.
Posted May 05, 2026 - 09:09 CDT

Investigating

The student game is experiencing a temporary loading delay but will be back up and running soon. We’re looking into it and will update here shortly!
Posted May 05, 2026 - 07:28 CDT
This incident affected: Boddle Game.