Student Game Temporarily Unavailable for Certain Users

Incident Report for Boddle Learning

Resolved

The game should be back up and running for all users! If you run into any trouble, please let us know at contact@boddlelearning.com
Posted Aug 21, 2025 - 13:44 CDT

Investigating

The student game is experiencing a partial outage, and certain users may experience an error upon signing in. We’re looking into it and will update here shortly!
Posted Aug 21, 2025 - 12:53 CDT
This incident affected: Boddle Game.