Student Game Temporarily Unavailable – We’re On It!

Incident Report for Boddle Learning

Resolved

We're back up and running at full speed! Thanks so much for your patience as our team resolved this.
Posted Aug 21, 2026 - 13:41 CDT

Identified

Our developers have identified the issue and are making some changes. Stay tuned for updates!
Posted Aug 21, 2026 - 13:35 CDT

Investigating

The student game is experiencing temporary delays but will be back up to full speed soon. We’re looking into it and will update here shortly!
Posted Aug 21, 2026 - 13:15 CDT
This incident affected: Boddle Game.