Slow Loading Possible – We’re On It!
Incident Report for
Boddle Learning
Resolved
Everything is back up and running as normal!
Posted
Oct
24
,
2025
-
15:19
CDT
Investigating
One of our servers is experiencing some downtime, so some users may see longer loading times when signing in. We're working on a fix and will update here shortly!
Posted
Oct
24
,
2025
-
13:20
CDT
This incident affected: Boddle Game.
×
Subscribe to Incident
Subscribe to updates for
Slow Loading Possible – We’re On It!
via . You'll receive .