Boddle Racers Maintenance Underway

Incident Report for Boddle Learning

Update

We are continuing to work on a fix for this issue.
Posted Nov 17, 2025 - 08:26 CST

Update

We are continuing to work on a fix for this issue.
Posted Nov 14, 2025 - 10:01 CST

Identified

Our developers are working on some fixes to our Boddle Racers game modes. While these fixes are in progress, students may be unable to access Grand Prix mode, host a race, or join a teacher-hosted race.

Thanks for your patience. We'll keep you posted as we get closer to a resolution!
Posted Nov 12, 2025 - 14:54 CST
This incident affects: Boddle Game.