Student Game Temporarily Unavailable – We’re On It!

Incident Report for Boddle Learning

Resolved

The game is back up and running at full speed! Thanks so much for your patience as we resolved this issue.
Posted Sep 05, 2025 - 14:11 CDT

Investigating

The student game is experiencing a temporary outage but will be back up soon. We’re looking into it and will update here shortly!
Posted Sep 05, 2025 - 13:00 CDT
This incident affected: Boddle Game.