Student Game Temporarily Unavailable – We’re On It!

Incident Report for Boddle Learning

Resolved

The game is back up and running at full speed! If you run into any issues, please let us know at contact@boddlelearning.com.
Posted Sep 08, 2025 - 13:42 CDT

Investigating

The student game is experiencing a temporary outage but will be back up soon. We’re looking into it and will update here shortly!
Posted Sep 08, 2025 - 13:29 CDT
This incident affected: Boddle Game.